Cisco 6to4 Public Relay Service.

6to4 tunnels and connections to a 6to4 relay service need not be requested or negotiated between customers and the ISP.
The ISP simply configures the 6to4 relay service and customers can automatically connect to the service whenever they like.

Because of the one-to-many relationship between the 6to4 relay service and each 6to4 tunnel (each customer), there is low maintenance and management overhead associated with 6to4 tunnels and a 6to4 relay service. However, given that customers use the IPv4 address of their border router to construct the 6to4 address that they use to connect to the 6to4 relay service (they are not delegated a /48 prefix from the ISP), the ISP may want to manage the IPv4 routing announcements for the relay service to control its use (the ISP will need IPv4 traffic statistics to identify individual customers for using the service).

Reverse 6to4 delegation can be requested at: http://6to4.nro.net/.

Configuration example for 6to4 public relay on a Cisco 7600 platform:

Note: In the following example, additional addressing on Loopback (IPv4 and IPv6 on Lo64 below) is not obligatory.

!
interface Loopback64
 ip address XXX.XXX.XXX.XXX 255.255.255.255 secondary
 ip address 192.88.99.1 255.255.255.0
 no ip redirects
 ipv6 address 2002:XXXX:XXXX::1/128
 ipv6 enable
 ipv6 mtu 1280
 no ipv6 redirects
 no ipv6 unreachables
!
interface Tunnel64
 no ip address
 no ip redirects
 ipv6 address 2002:C058:6301::/128 anycast
 ipv6 unnumbered Loopback64
 ipv6 enable
 ipv6 mtu 1280
 no ipv6 redirects
 tunnel source Loopback64
 tunnel mode ipv6ip 6to4
 tunnel path-mtu-discovery
!
ipv6 route 2002::/16 Tunnel64
!
router bgp <ASN>
!
 address-family ipv4
  redistribute connected route-map TO-BGP
!
 address-family ipv6
  redistribute static route-map TO-BGP6
!
route-map TO-BGP permit 10
 match ip address prefix-list <ASN>:6to4-Anycast
 set local-preference 200
 set community <ASN>:YY <ASN>:ZZ
!
route-map TO-BGP6 permit 10
 match ipv6 address prefix-list <ASN>:6to4
 set local-preference 200
 set community <ASN>:YY <ASN>:ZZ
!
ip prefix-list <ASN>:6to4-Anycast seq 5 permit 192.88.99.0/24
ipv6 prefix-list <ASN>:6to4 seq 5 permit 2002::/16
!

Comments are closed.